Engine code - misfire cylinder one and random other code

Discussion in 'Subaru Levorg General Discussion' started by Ricer77, Jan 31, 2020.

  1. Ricer77

    Ricer77 New Member

    Joined:
    Sep 3, 2018
    Messages:
    9
    Likes Earned:
    1
    Location:
    Nz
    Hi guys, it took me almost a year to work this out so thought I would share Incase someone has the same problem as me / is googling this problem.

    P0301 fault code came up

    also had hill start assist warning light and check engine light.

    So, after swapping all plugs, juggling all of the coil packs to move the fault, checking all of the wiring, (car feeling tougher as time went on ) , I got crashed into and whilst the car was being repaired the battery went flat multiple times. This had happened twice when I went away on holidays longer than a week or two within the year.

    Checked the battery and it was the factory battery. My levorg has done over 100k kms now.

    Replaced the Q85 battery (that’s the code of you ever need that).

    car runs like never before. All codes cleared. I was sure that my hill start was stuffed and that I had an injector issue.

    Symptoms -
    -rough idle
    -Skip when accelerating from idle or quick give ways
    -fault codes and lights
    -loss of steering wheel controls when faulting
    -fault would clear and then randomly appear again


    any
     

    Attached Files:

    Arkatee likes this.
  2. nicodache

    nicodache Active Member

    Joined:
    Jun 23, 2014
    Messages:
    171
    Likes Earned:
    28
    Location:
    50.45459,3.95254
    Thanks for this, my 'Vorg has 90k ATM. I'll keep an eye on weird stuff my car would end up doing :D
     
  3. Robbo

    Robbo New Member

    Joined:
    Monday
    Messages:
    3
    Likes Earned:
    0
    I had a similar issue, can’t recall the fault codes but it was due to the post-cat o2 (oxygen) sensor.
     

Share This Page