LED HEADLIGHTS "headlights disabled"

robo498

Active Member
Joined
Sep 19, 2020
Messages
139
Location
Melbourne Australia
Vehicle(s)
My17
Hello all, I have 2017 GTS 2.0 LEVORG (Australian) with the cameras and LED headlights and fog lights. After the last service around a month ago I was driving at night and "headlights disabled" suddenly popped up on the screen and the drivers side headlight went out. When I got home I pulled all the fuses and they were all OK? But the lights started working again! Now a month later the same thing has happened again....again I pulled the fuses and swapped them around just in case the fuses were faulty, again they worked until the next morning when I turned right (yep a right turn) and the drivers side went out again. So turned them off and on again (this time not AUTO, full ON) and they came back on and stayed on? Now subaru charge over 2k for a headlight! Anyone got any ideas what I should do? I see on the WRX & FORESTER forums they have also had this issue but I could not find a fix other than to replace the light......warranty finished last month

Thanks guys.
 

nicodache

Active Member
Joined
Jun 23, 2014
Messages
293
Location
50.45459,3.95254
Any chance you could still ask them to try & pull codes from the ECU (if any) and confirm it's reported as failing light ?

Those staying on when you put them in manual mode, and turning off when you're on auto mode is weird.
 

Guvna

Active Member
Joined
May 18, 2017
Messages
255
Location
Victoria, Australia
Vehicle(s)
MY17 Subaru Levorg 2.0LTR GTS
Just out of warranty that’s harsh. Run the code is a good idea, also wiring check, done any mods under there? Failing that before I’d buy new ones from Subaru at 2grand I’d check the wreckers for a 2nd hand one, or go after market for cheaper too.
 

robo498

Active Member
Joined
Sep 19, 2020
Messages
139
Location
Melbourne Australia
Vehicle(s)
My17
Ebay Japan has some for around 1k for 2 but the part number is a little different? Maybe because they are JDM? I can only hope they would be the same as mine? As for the codes I have an OBD2 reader and software on my phone, wonder if that would work?
 

Guvna

Active Member
Joined
May 18, 2017
Messages
255
Location
Victoria, Australia
Vehicle(s)
MY17 Subaru Levorg 2.0LTR GTS
Worth a look, the killer with parts from Japan is that it costs almost as much again for the postage.
 

robo498

Active Member
Joined
Sep 19, 2020
Messages
139
Location
Melbourne Australia
Vehicle(s)
My17
Again today the drivers side would not come on at all. .....used the OBD2 reader but it said no error codes. Looks like a 2nd hand set of head lights from Japan. ....This is crazy someone must have a fix for this! These are LED, and should last three life of the car, its only been 3 years! Hope the car lasts longer than that.
 

robo498

Active Member
Joined
Sep 19, 2020
Messages
139
Location
Melbourne Australia
Vehicle(s)
My17
Well, update. .....drivers side stopped completely now. Has not come on for over a week a now. I left them on auto and was working fine, then I turned them off in error, for it to never come on again, very strange! The only mod I have done is put in an auto window/mirror closer. Any ideas? Subaru want $200 to find the problem (bet they say it needs a new headlight $$$$$$)
 
Top