Start up warning lights

Doogz32

New Member
Joined
Aug 29, 2020
Messages
20
Vehicle(s)
2018 Levorg GTS 2.0
Hi folks,

Since yesterday, my levorg has decided to display warning lights on the dash upon start up (i.e eyesight off, check engine light on, lane assist off, obstacle detection off, traction control off, etc) with a msg saying check owner's manual.

Couldn't find anything in the manual about a situation where this occurs and what to do. Before I call the dealership for a service/check, just wanted to run this by the brains trust here in case anyone else has experienced this and whether there's an easy fix.

Car seems to run fine otherwise, it's just the presence of all the lights that's worrisome ... especially to the Mrs.

Anyways, hope everyone had a safe Easter. Looking forward to the upcoming long weekend!

Cheers,
Marco
 

Attachments

Guvna

Active Member
Joined
May 18, 2017
Messages
255
Location
Victoria, Australia
Vehicle(s)
MY17 Subaru Levorg 2.0LTR GTS
G'day Doogz,
Totally understand the worry these lights bring on. Quick question for you, have you had a flat battery lately? I've just had to replace my battery recently (it lasted just shy of 5 years). Whenever the old one went flat (2 or 3 times), I would disconnect it from the car and charge it overnight. Upon reconnecting the battery I would have the same warning lights you have described illuminate on my dash. Also the power windows auto function would'nt work, and the drivers door controls would not activate the other 3 windows at all. Simply driving the car for a while, sometimes for even several stop starts, the car would recalibrate itself and these warning lights would go away on their own. The windows on the other hand need to be reset manually on each door control separately, by doing the following to each door. Press and hold the window down control and continue holding it down for approx 5 seconds after it reaches the bottom. Then pull the window switch up until the window is totally closed and continue to hold the switch up for approx 5 seconds. The window controls for that door should now function as normal. Repeat this procedure for the remaining doors and all windows and switches will function correctly. I'm hoping that your battery has indeed gone flat recently, that way these problem warning lights will rectify themselves. Hope this helps mate.
 

robo498

Active Member
Joined
Sep 19, 2020
Messages
139
Location
Melbourne Australia
Vehicle(s)
My17
When the eyesight is off the 2 lights at the bottom come on (has happened to me when the windscreen fogged up) when it cleared eyesight came on and the 2 bottom lights went out. You need to plug into the OBD2 plug and see what the check engine light is all about. I think supercheap auto can do that for you? Please let us know how you go. Good luck!
 

Doogz32

New Member
Joined
Aug 29, 2020
Messages
20
Vehicle(s)
2018 Levorg GTS 2.0
Thanks @Guvna and @robo498. After work yesterday, I was still experiencing the same issue as I made my way to pick up bub from daycare. But when I left the centre, the problem no longer presented itself. Had turned the engine on and off a couple more times last night, and no issues at all, no beep sound on start up and warning lights. Still strange to me that it happened then went away without no apparent reason ... but kinda glad it's gone for now.

I doubt it had anything to do with the dash cam having SD card issues around the same time (which I had reformatted). It does connect to the cigarette lighter socket, maybe some kind of electrical-related fault that threw things off?

All good for now!
 

Guvna

Active Member
Joined
May 18, 2017
Messages
255
Location
Victoria, Australia
Vehicle(s)
MY17 Subaru Levorg 2.0LTR GTS
Thanks @Guvna and @robo498. After work yesterday, I was still experiencing the same issue as I made my way to pick up bub from daycare. But when I left the centre, the problem no longer presented itself. Had turned the engine on and off a couple more times last night, and no issues at all, no beep sound on start up and warning lights. Still strange to me that it happened then went away without no apparent reason ... but kinda glad it's gone for now.

I doubt it had anything to do with the dash cam having SD card issues around the same time (which I had reformatted). It does connect to the cigarette lighter socket, maybe some kind of electrical-related fault that threw things off?

All good for now!
Sweet, good to hear.
 
Top