Blackout started.

Discussion in 'Member's Car Gallery' started by LevorgBlackOut, Mar 18, 2017.

  1. Rasputin1969

    Rasputin1969 New Member

    Joined:
    Feb 28, 2017
    Messages:
    24
    Likes Earned:
    1
    i thought it had to be in S# mode?

    As you can tell I haven't tried it yet.:)
     
  2. trucker

    trucker New Member

    Joined:
    Mar 26, 2017
    Messages:
    4
    Likes Earned:
    0
    So it definitely works here? I had a bit of a try and it felt like the car was still pressing to go. Its a new car so I didn't push it too hard. Just had a play.
     
  3. AKKO

    AKKO Member

    Joined:
    Apr 26, 2017
    Messages:
    137
    Likes Earned:
    13
    Can't find a reference to this system (specific to the Levorg) only cat back options, anyone know if it's been discontinued?

    Made for WRX I assume...
     
    Last edited: Jul 28, 2017
  4. pretenda

    pretenda New Member

    Joined:
    Jul 1, 2017
    Messages:
    2
    Likes Earned:
    0
    I know this is a late reply, but i've not long gotten my levorg. Mine has it, MY17 in australia. I don't have to be in any particular mode, it seems to work no matter what.
     
  5. trucker

    trucker New Member

    Joined:
    Mar 26, 2017
    Messages:
    4
    Likes Earned:
    0
    How do you know its working ?
     
  6. pretenda

    pretenda New Member

    Joined:
    Jul 1, 2017
    Messages:
    2
    Likes Earned:
    0
    I just put my foot on the brake, gently pushed my foot on the go pedal, it topped it at 2500rpm on the nose, then let go of the brake and it went like a rocket.
     

Share This Page